A Unix Mind In A Windows World .

Chroniques tech et pérégrinations digitales. Opinons incluses.

Post Page Advertisement [Top]

Si vous utilisez Views et jQuery Update, vous n'êtes pas sans savoir que les 2 composants ne font pas bon ménage ensemble.

Le problème ici est que la version de jQuery compatible avec l'interface de Views n'est pas des plus récentes, et que, comme son nom l'indique, jQuery Update met à jour la version de jQuery vers une des dernières versions. La solution ici est donc de désactiver la version de jQuery importée par jQuery Update lorsqu'on se trouve dans l'interface d'administration.
Pour ce faire,
  1. connectez vous via ftp, et allez dans le dossier sites/all/modules/jquery_update. 
  2. Ouvrez le fichier jquery_update.module et remplacez son contenu par le contenu ci dessous (qui est un patch trouvé sur les forums de Drupal)
Loading ....
  • Ouvrez ensuite l'interface d'adminsitration de drupal , et allez dans le menu /admin/config/development/jquery_update . 
  • Dans la zone "Switch JQuery on specific pages " collez les valeurs ci dessous 
admin* 
imagebrowser* 
img_assist* imce* 
node/add/* 
?q=admin* 
node/*/edit 
print/* 
printpdf/* 
system/ajax system/ajax/* 
Vous pourrez ensuite mettre à jour vos vues sans avoir à vous soucier de problèmes de compatibilité.

Aucun commentaire:

Bottom Ad [Post Page]

| Designed by Colorlib | (Heavily) Modified by Jean Luc Houedanou