A Unix Mind In A Windows World .

Chroniques tech et pérégrinations digitales. Opinons incluses.

Post Page Advertisement [Top]


"This version is not compatible with Drupal 7.x and should be replaced" : derrière ce gloubi glouba issu de la langue de Shakespeare se trouve, à mon avis, l'erreur que rencontreront à tous les coups ceux et celles qui se lancent dans la conception d'un thème Drupal.
Plus qu'une erreur, il s'agit d'une pierre d'achoppement qui peut dégouter à tout jamais ceux et celles qui se lancent dans l'aventure Drupal : en effet, il est impossible d'activer le thème qu'on est entrain de développer sans la résoudre, et il faut avouer que les multiples posts sur le sujet présents sur les forums de Drupal sont d'une grande inutilité.


Cela dit, sous ses apparences complexes, ce problème a une solution toute simple  . 
Il faudra rajouter à votre fichier .info la ligne suivante 
 regions[content] = contenu principal 
puis vider le cache du thème et enfin admirer le résultat.

 

En effet, afin de fonctionner correctement, tout thème Drupal a obligatoirement besoin d'une région dénommée "content" . Son absence entraîne l'apparition de la fameuse erreur  "This version is not compatible with Drupal 7.x and should be replaced" . 
De rien :) 




Aucun commentaire:

Bottom Ad [Post Page]

| Designed by Colorlib | (Heavily) Modified by Jean Luc Houedanou