Depuis le 30 septembre 2021 à 16h01, vous avez sûrement un message d’erreur qui s’affiche sur Safari, si vous êtes sur une version antérieure de MacOS ( El Capitan et en dessous).

Comment résoudre l’erreur NET::ERR_CERT_DATE_INVALID sur El Capitan ( MacOS 10.11), A Unix Mind In A Windows World

Sur les autres navigateurs, bon nombre de contenus, tels les images et les vidéos devraient ne s’affichent plus … sauf si vous utilisez Firefox ( ce qui prouve, une fois de plus, que ce navigateur est sous estimé ).

Cela est dû à l’expiration d’un « certificat racine », ou pour faire simple, un mécanisme de sécurité internet inclut dans votre ordinateur ( plus précisement dans l’application « trousseau d’accès ») qui vérifie la conformité du site web que vous souhaitez visiter . La version de ce certificat pour les « vieux » appareils Apple, tel l’iMac 2009 ( que j’utilise pour alimenter ce blog) a expiré le 30 septembre 2021 et Apple ne prévoit pas de collaborer avec son émetteur afin de renouveller.
(sont également concernés les appareils iOs inférieurs à iOS 10 , ainsi que les appareils Android tourant sur une version inférieure à Android 7.1)

Deux solutions s’offrent donc à vous .

1 – Installer Firefox ( la plus simple).

2 – Mettre les mains dans le cambouis et donc le renouveller à la main . Pour ce faire;

  • Allez récupérer la version la plus récente du certificat ici .
  • Ouvrez le trousseau de clés, et allez dans le menu « fichier » , « importer »
  • Allez ensuite dans le menu « certificats » , et double cliquer sur l’élément ISG ROOT X1
  • Enfin, dans la zone « Se fier » , activez le certificat .

Redémarrez ensuite Safari et/ou Chrome .

Jean Luc Houédanou

Leave a comment

Votre adresse e-mail ne sera pas publiée. Les champs obligatoires sont indiqués avec *